Firmware Build v9.0 2018.42.2.1 e1784f9 (11/6/2018)

  • Please post everything related to v9 (2018.39.x) into the version 9 MEGATHREAD. Please do your part to keep this site organized for everyone by looking around or doing a search BEFORE posting. Thanks

  • Winter is here and the forum is starting to get flooded with cold weather threads and posts. Please heed the suggested threads and posts before you post something related to cold weather. This is a great place to start: https://model3ownersclub.com/threads/teslas-in-cold-weather.5271
  • It's OK to discuss software issues here but please report bugs to Tesla directly at servicehelpna@teslamotors.com if you want things fixed.

DanInSD

New Member
Joined
Aug 11, 2018
Messages
3
Location
San Diego
Tesla Owner
Model 3
Country
Country
#2
I just got it this morning. The release notes were no different. I already had Autopilot on Nav. I was surprised because I knew that 42.4 was already out. I'm always open to a new release if it's specifically fixing something.
 

iChris93

Top-Contributor
M3OC Supporting Member
Joined
Feb 3, 2017
Messages
599
Location
Ann Arbor, MI
Tesla Owner
Model 3
Country
Country
#3
I just got it this morning. The release notes were no different. I already had Autopilot on Nav. I was surprised because I knew that 42.4 was already out. I'm always open to a new release if it's specifically fixing something.
What version did you come from?
 

LUXMAN

Legendary Member
M3OC Supporting Member
Joined
Apr 4, 2016
Messages
2,617
Location
Lantana, Texas
Tesla Owner
Model 3
Country
Country
#4
I posted on 42.4 as well as I just saw this thread.

Interestingly I just went from 42.2 to 42.2.1

Mobile service came today and the invoice says upgraded to latest software but he left almost 3 hours before it came.

headed out to see what the notes, if any say?
Why this vs 42.4?

EDIT. Same notes as 42.2 Key Fobs and increased regen
 

Meg

Member
Joined
Dec 20, 2016
Messages
5
Location
Whitwell, TN
Tesla Owner
Model 3
Country
Country
#7
I have no Autopilot, no radar view of cars, no cruise control, no speed limit shown, No auto high beam
They are suppose to fix those of us without... maybe that is why??
6EAF43D9-AA87-46CC-8E34-0AD2BF51343F.jpeg
 

Drhalo

Active Member
Joined
Jul 11, 2018
Messages
84
Location
USA
Tesla Owner
Model 3
Country
Country
#8
Just had a ranger at my house to fix a lifting stock and fix a lifting mirror trim. The ranger asked if I wanted them to push the update to which I said YES.
I was on 42.2, and now am on 42.2.1. I wasn't having any issues with 42.2 like others have mentioned. There was no option for 42.3 or 42.4, and the assumption they had was it was pulled by engineering. Obviously they couldn't confirm it.
 

datum

New Member
Joined
Nov 8, 2018
Messages
1
Location
Lake Forest, CA
Tesla Owner
Model 3
Country
Country
#11
I also just upgraded from 42.2 to 42.2.1, but have no clue of the implications. It would be lovely if, along with the notification and request for approval to install, we'd receive a summary of the bug fixes and/or features.
 

Mark S.

New Member
Joined
Feb 25, 2018
Messages
2
Location
Cleveland, Ohio
Tesla Owner
Model 3
Country
Country
#12
My update from 42.2 (I assume it was 42.4) had an error last weekend so I waited to see if it would retry. I was updated to 42.2.1 yesterday and then 42.4 was received and installed overnight. I am guessing that 42.2.1 is a transitionary update to fix whatever was causing the 42.4 update to fail.
 
Joined
Sep 29, 2018
Messages
8
Location
Merritt island, Florida
Tesla Owner
Model 3
Country
Country
#13
Yes - I got 42.2.1 update yesterday while at service center in Orlando. They decided to check side cameras because of the lost of Autopilot earlier in the week. Found nothing wrong. I installed 42.2.1, but no notes (so who knows what it fixed). BTW I was on 42.2 already no problems with this software update
 

BobbyM3

Active Member
Joined
May 26, 2018
Messages
41
Location
Texas
Tesla Owner
Model 3
Country
Country
#17
Same here I just got the update from 42.2 to 42.2.1. Was expecting 42.3 at least. I noticed when I was driving to work this am I didn’t have any LTE. Got to work and rebooted with the two button press method and then got LTE only after I connected to work WiFi. It wasn’t until it connected to the WiFi network that suddenly the LTE showed up at full strength too. Weird.
 

BigBri

Top-Contributor
Joined
Jul 16, 2016
Messages
855
Location
Toronto, Ontario
Tesla Owner
Model 3
Country
Country
#18
Just got this today. Took less than a minute to install. Was hoping this was to re-enable the AP trial for those of us that tried it on V8 but this FW seems to predate the tweet Elon made.