Symbols missing in Safari

Juergen

Active Member
Joined
Jan 22, 2017
Messages
59
Location
Messstetten
Country
Country
#1
Hi,

in Mac OS Safari light style are some symbols missing. I make 2 screenshots to see the difference.
On top is Firefox and below is Safari.
I'm using MacOS El Capitan 10.11.6 on iMac 20" early 2008.
Firefox_vs_Safari_light.png

Firefox_vs_Safari_dark.png
You can see the squares in the light style.
Is not easy to navigate without to see whats behind.


Juergen
 

garsh

Dis Member
Moderator
M3OC Supporting Member
Joined
Apr 4, 2016
Messages
7,601
Location
Pittsburgh PA
Tesla Owner
Model 3
Country
Country
#2
That looks like a caching issue. Try an ignore-cache page reload (hold down SHIFT, then hit the page reload button).

I'm not familiar with "Safari Light Style", and a quick search didn't turn up anything. Can you give me a link that explains this feature?
 

Juergen

Active Member
Joined
Jan 22, 2017
Messages
59
Location
Messstetten
Country
Country
#3
Thanks for the quick response!

You can switch the M3OC style if you scroll down. Then you see the M3OC Dark or M3OC light menu button.
It is in the dark gray footer. A click on it open a window to choose the style.
 

garsh

Dis Member
Moderator
M3OC Supporting Member
Joined
Apr 4, 2016
Messages
7,601
Location
Pittsburgh PA
Tesla Owner
Model 3
Country
Country
#4
You can switch the M3OC style if you scroll down. Then you see the M3OC Dark or M3OC light menu button.
It is in the dark gray footer. A click on it open a window to choose the style.
Thanks! I understand now.

Did you try a shift-refresh?
 

JWardell

Legendary Member
Joined
May 9, 2016
Messages
2,305
Location
Boston
Tesla Owner
Model 3
Country
Country
#6
Strange. I use safari and the light theme and have no issues with those graphics loading. They are the down arrows to indicate a menu appears if you hover over the word, so it shouldn't affect functionality.

You could also try holding down over the reload button in the address bar, and selecting Reload without Content blockers.
It's possible you have a adblocker or other plugin that is blocking them.
 

Juergen

Active Member
Joined
Jan 22, 2017
Messages
59
Location
Messstetten
Country
Country
#7
Maybe this is a language thing. I have german as system language.
By the other hand, why I have no issues with the dark style.
In the light style is the alert bell invisible, but the popup window appear if I hover with the mouse pointer over it. I'm now an my second mac which is a old Macbook Pro late 2008. I have here the same issues as the iMac with same software.
The different kind of reload the site and deactivate safaris own blocker have no impact.
 

SoFlaModel3

@Teslatunity
Moderator
M3OC Supporting Member
Joined
Apr 15, 2017
Messages
8,851
Location
Florida
Tesla Owner
Model 3
Country
Country
#8
Maybe this is a language thing. I have german as system language.
By the other hand, why I have no issues with the dark style.
In the light style is the alert bell invisible, but the popup window appear if I hover with the mouse pointer over it. I'm now an my second mac which is a old Macbook Pro late 2008. I have here the same issues as the iMac with same software.
The different kind of reload the site and deactivate safaris own blocker have no impact.
I get the sense you're right, it may be a language thing if there is a conversion happening on your end.

Did you update to MacOS High Sierra? Still have the issue?
 

TrevP

M3OC Founder / Administrator
Founder
Joined
Mar 1, 2016
Messages
5,970
Location
Aurora,Ontario
Tesla Owner
Model X
Country
Country
#11
The squares you are seeing is because your browser is not loading everything over SSL, in this case the Font Awesome fonts which are responsible for the icons. Everything works for me in both Safari/Chrome, FF 55.x on El Cap, Sierra and High Sierra.

Clear your browser caches and try it again....

Also, make sure you have the latest version of each browser. They're getting very tight with SSL requirements now (no mixing of secure and unsecure resources)
 

SoFlaModel3

@Teslatunity
Moderator
M3OC Supporting Member
Joined
Apr 15, 2017
Messages
8,851
Location
Florida
Tesla Owner
Model 3
Country
Country
#13
The another browser works well.

Browser cleaning doesn’t work for me.
Why are the problems only in light style? You can see this in my first post.
I hadn't noticed that the issue was only one theme and not the other that is strange. My only inclination would be to clear cache. In Safari go to File > New Private Window. If it works there, it's definitely something stored locally. If it doesn't work there I'm just about stumped (I don't have access to anything behind the scenes with code though).
 

TrevP

M3OC Founder / Administrator
Founder
Joined
Mar 1, 2016
Messages
5,970
Location
Aurora,Ontario
Tesla Owner
Model X
Country
Country
#16
If you have an Adblocker that could also be the cause. Whitelist our site, we don't have ads
 

Juergen

Active Member
Joined
Jan 22, 2017
Messages
59
Location
Messstetten
Country
Country
#17
I've tried different things.
I changed the Mac to English. Without success.
I tried a new private window. Without success.
I disabled the add blocker. Without success.
Do you have any other suggestions?
Screen Shot 2017-10-03 at 18.20.10.png
Maybe the screenshot will help?