Timer wrong

Michel Zehnder

Well-Known Member
Joined
May 10, 2016
Messages
277
Location
Zurich, Switzerland
Tesla Owner
Reservation
Country
Country
#1
The Model 3 Delivery event timer is wrong. It seems to count to 7PM local-time instead of PST.
(Here in Switzerland it says the event will take place Friday, 28th, 7pm (we are UTC+2), it should be Sat, 29th, 4am here)

Cheers
Michel
 

Michel Zehnder

Well-Known Member
Joined
May 10, 2016
Messages
277
Location
Zurich, Switzerland
Tesla Owner
Reservation
Country
Country
#9
@TrevP You might want to change to UTC time by setting utc:1 and adjust the date/time properly to UTC time. That might work:
Code:
countDown({targetDate:{'day':28,'month':7,'year':2017,'hour':19,'min':0,'sec':0,'utc':0}})
should get to this:
Code:
countDown({targetDate:{'day':29,'month':7,'year':2017,'hour':02,'min':0,'sec':0,'utc':1}})
 

garsh

Dis Member
Moderator
M3OC Supporting Member
Joined
Apr 4, 2016
Messages
7,601
Location
Pittsburgh PA
Tesla Owner
Model 3
Country
Country
#11
It looks like the calculation believes the event is at 7pm in the local user's timezone instead of PDT.
 

TrevP

M3OC Founder / Administrator
Founder
Joined
Mar 1, 2016
Messages
5,970
Location
Aurora,Ontario
Tesla Owner
Model X
Country
Country
#13
I need some help figuring this out a bit. I just enabled the timer to Sync with UTC. I have the time set to 19:00 on the 28th. Is that correct? How much +_ do I need to adjust?
 

garsh

Dis Member
Moderator
M3OC Supporting Member
Joined
Apr 4, 2016
Messages
7,601
Location
Pittsburgh PA
Tesla Owner
Model 3
Country
Country
#15
I need some help figuring this out a bit. I just enabled the timer to Sync with UTC. I have the time set to 19:00 on the 28th. Is that correct? How much +_ do I need to adjust?
I think 7pm PDT 28th == 2am UTC 29th.
 

TrevP

M3OC Founder / Administrator
Founder
Joined
Mar 1, 2016
Messages
5,970
Location
Aurora,Ontario
Tesla Owner
Model X
Country
Country
#18
@TrevP If you set your timer for UTC 29th 2am July that will be equal to 28 th July 7pm Pacific time.

The timer is calculating based on your local time

OK, I set it like that but it doesn't display based on your local time I'll just have to lock it to 7PM PST and leave it like that